Do I need an updated version of OS X to use the macOS app?

Noun Project for Mac works with OS X versions 10.9 and higher. Please be sure to update your computer before downloading the app.

Have more questions? Submit a request
Powered by Zendesk