An error messages says I need a newer version

1) First, check your compatibility. You can use the add-in with Microsoft PowerPoint and Word. Microsoft Office 365 for PC, Mac, or Web is required.

Specifically:

  • PowerPoint 2013 Service Pack 1 or later
  • PowerPoint 2016 for Mac
  • PowerPoint 2016 or later
  • PowerPoint Online
  • Word 2013 Service Pack 1 or later
  • Word 2016 for Mac
  • Word 2016 or later
  • Word Online

2) Upgrade Microsoft Office.

3) Try opening PowerPoint/Word first then click the add-in link to install. This may resolve the problem.

4) Try re-installing the add-in by selecting ‘Store’ (within the program) to find our add-in, instead of installing from the link we provided.

Have more questions? Submit a request
Powered by Zendesk